Ansible requirements on OpenWrt

I’ve setup Ansible on my Raspberry Pi 3, so that I can manage updates for all my servers from one central location. However, OpenWrt does not come with Python installed (which Ansible depends on). According to the wiki, the regular python package is around 50MB, which is way larger than my ROM space. The python-light package is small enough, but is missing some modules. Below are the packages you’ll need to get Ansible working.

opkg install python-light python-codecs python-logging python-openssl

Hope this helps!

Logan

 

Leave a Comment